Symptom
It is observed that the nudge notification title is not sent in the right language. The content of the notification is sent in the correct language, but the title is not.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to Settings > Change the language to any other language other than English
- Go to Onboarding Dashboard and search for an Onboardee
- Find any unfinished task and nudge the assignee
- Go to Email Services, you will see that the Subject for the email is in English and not in language chosen earlier
Cause
- The notifications are sent based on the Company's locale. This can be set from Provisioning site.
- For Nudge Assignee however, the email body is generated from the Nudge popup which gets translated based of the locale selected from Settings. But this will not apply to other emails sent from this account.
- Since for Nudge Assignee we only allow the admin to write the Email body from within the Nudge Assignee feature the Email Body is in a different language while the Email Subject is still in English.
Resolution
For the email body and its subject to be sent in a specific language there are 2 ways,
- You can set the company locale to the desired language from provisioning site. This will however send all emails from all accounts in this company in the locale specified.
- (Recommended) You can set the locale based on Rules.
- You can create a rule to set a specific email template to desired locale based on conditions from 'Manage Business Rules'
- You then need to add this rule in the specific email template in Step 2 under 'E. Language Selection Business Rule'
- With this there will be no need to modify the language from Settings every time you send an email.
- Reference Link: https://help.sap.com/viewer/c94ed5fcb5fe4e0281f396556743812c/2105/en-US/13cf42adfd0843e0ba1973388913a10e.html
Keywords
Nudge Notification. Nudge Assignee, Nudge, Email Notifications , KBA , LOD-SF-OBX-EML , Notifications , How To
Product
SAP SuccessFactors Onboarding 2105