SAP Knowledge Base Article - Public

3066608 - [Onboarding] Candidates do not appear in onboarding dashboard after initiation from RCM (Onboarding/Offboarding)

Symptom

Candidate whose Onboarding Process was initiated from RCM, does not appear in dashboard. The candidate's Onboarding Workflow fails due to error.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  • Initiate onboarding for candidates from RCM
  • Candidates do not appear in Onboarding Dashboard
  • Check the process object of the candidate, Process Variant is not assigned
  • In BPE: Monitor Processes the Onboarding Workflow for the candidate fails due to an error

Cause

  • There could be different reasons for the Onboarding Workflow to fail. In this KBA we will be discussing error due to missing Picklist ecEmailType which has not been configured in Picklist Centre.
  • A support ticket can be created to get the exact error logs. Before that you can follow the steps mentioned in the resolution to perform the initial check on the data passed for the candidate from RCM.

Resolution

  • Kindly configure the picklist ecEmailType
  • Refer to the attachment for more details

Keywords

Onboarding Initiation from RCM, ecEmailType, Picklist Center, Onboarding2Workflow error , KBA , LOD-SF-OBX-PFE , BPE Process Flow Error Handling , Problem

Product

SAP SuccessFactors Onboarding 2105