Symptom
- How to provide access to Manage Documents when Onboarding 2.0 is enabled (external users)?
- Users are not able to see documents in the Manage Document tool anymore
- No documents visible under the Manage Documents feature
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Login to the instance
- Search the tool Manage Documents
- The user is able to open the tool, but no data is being shown
Cause
The root cause of this issue is that the Manage Documents page underwent an enhancement to display user metadata for onboardees (Onb2.0 external users) on the Manage Documents page along with the documents in the b2105 release. The user metadata was previously not available (blank).
To enable this, the Manage Documents page in b2105, calls the User OData API, filtered by user status to get to external user's metadata information (Status, User Name, Last Name, and First Name). This filter is needed because by default User Odata API will not return external users. This OData filter introduces an RBP check on the User Odata API side, and will only return results if logged-in users have appropriate access to view User Metadata. Since this RBP check was previously not done before b2105, it worked fine for the admin user. After the b2105 release since this admin user does not have the required permission, we see No Data issue.
Resolution
- Ensure that the affected users have the Manage Document Categories permission:
- It is also required to grant at least the View permission to affected user to fields below:
- Employee Data:
Status
First Name
Last Name
Username
- Employee Data:
See Also
2518360 - The Manage Documents Feature in SuccessFactors
Keywords
Manage documents not working, No data, no file , KBA , LOD-SF-PLT-DOC , Document Management , How To