SAP Knowledge Base Article - Public

3067390 - Unexpected Note Text Showing in Opportunity Report

Symptom

Two different note values for an opportunity are shown in a report.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Business Analytics work centre
  2. Go to the Design reports view
  3. Search for an opportunity report 
  4. In the field "Opportunity ID" enter the relevant ID 123 (123 represents the relevant opportunity)
  5. Add the fields "opportunity ID", "Notes" and "Notes (Opportunity)" to the view
  6. Run the report
  7. Here you will notice two different values for the notes field. Your expectation is, that it should only be one value in Notes(Opportunity)

Cause

If you had the notes history turned on at some point, but in the meantime changed the scoping, those notes would still be in the system.
In our example Opportunity 123 contains two instances of TextCollection-TEXT_CONTENT.

Therefore, the value shown in the report is quite arbitrary and the value of the two characteristics might deviate.

The UI supports several instances of TextCollection-TEXT_CONTENT only if the scoping question "Do you want to enable users to see earlier versions of opportunity notes?" is switched on.
As this scoping question is switched off in the system, the Opportunity UI shows only one note.

The second note value is not visible in the Opportunity UI. According to the scoping question the UI shows only the first note.

In Reporting, however, the second note can appear, too.

Resolution

The scoping question "Do you want to enable users to see earlier versions of opportunity notes?" determines the availability of these notes in both the Opp TI and the report, accordingly.

To check or change the settings:

  1. Go to the Business Configuration work centre
  2. Go to the Implementation Projects view
  3. Select and enter the relevant project 
  4. Navigate to step 4., Questions
  5. Expand Sales > New Business > Opportunities
  6. Select the question and as per your requirement either include or exclude it in the scoping
  7. Finish/Save and refresh the system. 

If you had the history turned on, but in the meantime changed the scoping, those notes would still be in the system.

If there are several Opportunities which might have this issue and some might have not only one additional text but sometimes several Versions/additional texts, then manual correction is not the ideal option here.

The Notes can be exported via Data Workbench Individual Object "Opportunity Notes", filtered by the Opportunity ID.

Via Data Workbench these notes can also be deleted (add column "ToBeDeleted" with value "True"; Update Individual Object).

But this should only be done, if really an issue is there.

Keywords

Note, Reporting, Notes, wrong, , KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer core applications 2105