Symptom
Export of Survery-Results runs into exception "An error occured. Try it again. Report an case, if the issue still exists".
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Surveys work centre view
- Open the relevant version of the respective survey
- Go to the Results facet
- Click Export
- After some time a pop-up appears: "An error occurred. Try it again. Report an case, if the issue still exists".
Cause
The system is trying to download all results across all version: surveys, assignments and answers. Depending on the volume, this may be beyond the system's capacity.
Resolution
Adapt the survey layout to include the 'Result Lists' section where you can filter down on the data volume before you export.
- Go to the Survey work centre view
- Open the relevant survey
- Enter Adaptation mode
- In the Results facet, select the Results section
- Navigate to 'Results' and make 'Result Lists' visible
- Save/ leave adaptation mode
- Now use the advanced search option in the 'Result Lists' section to filter smaller batches for export.
Keywords
Export, MS, Microsoft, Excel, dump, exception, error, no details , KBA , LOD-LE-SUR-DEF , Survey definition = design time , Problem
Product
SAP Cloud for Customer core applications 2105