Symptom
When trying to add a custom ad hoc time account to an employee time file, the time account created is not available
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Time Administration work center.
- Go to Employees view.
- Search and open the employee.
- Navigate to the Time Profile tab of the employee.
- In the Time Rules section on the bottom of the screen, add a new row.
- In the time account selection, the ad hoc time account created is not available.
Cause
The issue happens because the time account starting validity on the Business configuration activity is after the start date of the employee time profile. So by the time the employee profile started, the time account still did not exist.
Resolution
In order to fix this scenario, you would need to add a new time file that covers the validity of the ad hoc time account periods or change the ad hoc time account periods to match the time that they require to assign to an employee.
Keywords
Adhoc, time rule , KBA , SRD-HR-TLM , Time and Labour Management , How To