SAP Knowledge Base Article - Public

3067798 - BizX Daily Rules Processing Batch COMPLIANCE_METADATA_SYNC job is failing - Onboarding

Symptom

  • When running the BizX Dauly Rules Processing Batch in the back-end, the COMPLIANCE_METADATA_SYNC job is failing with the following error:

Full exception:com.successfactors.jobscheduler.ScheduledJobExecutionException: com.successfactors.jobscheduler.ScheduledJobInterruptedException: com.successfactors.jobscheduler.JobSchedulerException
Caused by: com.successfactors.jobscheduler.ScheduledJobInterruptedException: com.successfactors.jobscheduler.JobSchedulerException
Caused by: com.successfactors.jobscheduler.JobSchedulerException

Environment

  • SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Go to Provisioning >> Manage Scheduled Jobs.
  2. Search for job type: BizX Daily Rules Processing Batch.
  3. Run the job.
  4. Go to Provisioning >> Monitor Jobs.
  5. BizX Dauly Rules Processing Batch COMPLIANCE_METADATA_SYNC job fails.

Cause

  • Multiple active effective-dated records found in Country/Region object.
  • Print Form Service settings is not configured.

Resolution

  • For multiple active effective-dated records, please follow the steps below:
    1. Login to BizX.
    2. Go to Admin Center >> Manage Data.
    3. Search for the object Country/Region.
    4. Make sure that there is only one active effective-dated record for the following countries:
      1. Australia (AUS)
      2. Canada (CAN)
      3. United Kingdom (GBR)
      4. United States (USA)
  • For Print Form Service settings:
    1. Go to Provisioning >> Company Settings.
    2. Search for Enable Print Forms Generation.
    3. Enable the feature and provide the PFS basic authentication credentials.

See Also

KBA 2981870 - Unbale to see United States Record in Compliance Settings

Keywords

OBX, ONB2.0, Compliance, Metadata Sync, COMPLIANCE_METADATA_SYNC, BizX Daily Rules job failing, PFS, Print Form Service, Country/Region object, Compliance Settings , KBA , LOD-SF-OBX-ADM , Admin UI , Problem

Product

SAP SuccessFactors Onboarding