SAP Knowledge Base Article - Public

3069279 - "You cannot have a recovery with duplicate pay component within the period of this advance." even if installments are paid.

Symptom

While trying to request an advance, we get an error - "You cannot have a recovery with duplicate pay component within the period of this advance."

Although the advance is paid off via Manage Advance object>Accumulation for advances, we still cannot request it although we have remaining eligiblity

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

  • SAP SuccessFactors Employee Central - Advances 

Reproducing the Issue

1. Go to the advances section of the profile
2. Request an advance by filling in all relevant details.
3. Click save and you will see the error.

Cause

There is a date difference between when the advance was paid off, and when it's valid until


Resolution

The problem in the example above is that the inactive time slice is from 02/08/2021, now you are requesting the advance and getting an error because the deduction is going until 01/08/2021, meaning you can only request from 02/08/2021.

You can either make it paid before that, e.g. in June you paid, set status as paid and mark remaining balance as 0, so July and August will be marked as not relevant, and deduction will be closed by 01/06/2021, which means you will be able to request.

Also make sure that the endDate field is visible in RecurringDeductionItem object and the End Date for Deduction PayComponent in previous timslice is in line with date of timeslice where payComponent gets removed.

See Also

 2655185 - Error While Applying For A New Advance

Keywords

"You cannot have a recovery with duplicate pay component within the period of this advance." , paid, advance, installments, request, deduction, paid off, advance error, You cannot have a recovery , KBA , LOD-SF-EC-ADV , Advances , Problem

Product

SAP SuccessFactors Employee Central all versions