Symptom
For email template for Onboarding Restart (New Team Member Onboarding Restarted Template), instead of being default the LOGINTOKEN, it is using the Homepage Token [[HOME_PAGE]].
Due to the above, if your instance have SSO enabled or IAS enabled on the instance, your onboarding users will face the below issue:
- The on the link on Onboarding Restart notification will not allow the onboarding users to access as they are redirect to the SSO or IAS, which they do not have access to;
On the template, there is not the option to add the Login Token as shown on screenshot below:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding 2.0
Reproducing the Issue
- Login as an admin user;
- Go to Admin Center -> Email Services;
- Open the template (ONB) New Team Member Onboarding Restarted Template by clicking on it;
- Go to Step 3;
- You will see the template, select the link on the "Click here" on the text and click on the link icon;
- You will see that the link is referring to the Home page token [[HOME_PAGE]]
- If close the link editing and you click on the Insert Token, you will see that the login token is not available.
Cause
There is a product limitation.
Resolution
You need to manually create the link by adding the login URL for your onboarding users by creating the link on format below and use instead of the token:
<your DC URL>/login?company=<your company ID>&pm_product_name=ONB
Follow the steps below to provide your users with the correct url for access:
- Login as an admin user to your instance;
- Go to Admin Center -> Email Services;
- Open the template (ONB) New Team Member Onboarding Restarted Template by clicking on it;
- Go to Step 3;
- You will see the template, select the link on the "Click here" on the text and click on the link icon;
- You will see that the link is referring to the Home page token [[HOME_PAGE]], change it to the URL for your instance onboarding login on the format above;
- Replace <your DC URL> for your data center URL, for example https://performancemanager4.successfactors.com for DC4 (this url is what shows on the browser when you are logged in);
- Replace <your company ID> for your instance company ID;
Keywords
KBA , LOD-SF-OBX-EML , Notifications , LOD-SF-PLT-NOT , Email Notifications , Problem