Symptom
You have maintained the Warranty details under the Sales tab of Reference Product ID's: ABC master data (i.e. ABC refers to a Product ID). However, it doesn't update to a Registered Product:XYZ (i.e. XYZ refers to a registered product ID) in the system automatically when Inbound Delivery Notification and Inbound Delivery gets generated.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Entitlements work center.
- Go to Registered Products view.
- Show All Registered Products via drop-down and find ID:XYZ (i.e. XYZ refers to a registered product ID)
- Edit and under section: Warranty Assignment
- You find that system has not updated the Warranty Details as per Reference Product ID: ABC
Cause
Inbound Delivery Notification and Inbound Delivery creation doesn't assign a warranty from the reference product's warranty data automatically. User can assign a warranty manually for the relevant Registered Product.
Resolution
- Go to the Service Entitlements work center.
- Go to Registered Products view.
- Show All Registered Products via drop-down and find ID:XYZ (i.e. XYZ refers to a registered product ID)
- Edit and under section: Warranty Assignment
- Update Warranty Assignment details manually for registered product ID:XYZ (i.e. XYZ refers to a registered product ID)
This is an expected system behavior.
Keywords
Registered Product, Warranty, Reference Product Warranty, Start Date, end date, Reference product, Warranty Assignment , KBA , registered product , warranty , reference product warranty , start date, , end date , reference product , warranty assignment , AP-IDP-ID , Inbound Delivery , Problem