SAP Knowledge Base Article - Public

3070327 - Warranty Not Updated To Registered Product Automatically While Inbound

Symptom

You have maintained the Warranty details under the Sales tab of Reference Product ID's: ABC master data  (i.e. ABC refers to a Product ID). However, it doesn't update to a Registered Product:XYZ (i.e. XYZ refers to a registered product ID) in the system automatically when Inbound Delivery Notification and Inbound Delivery gets generated.

Environment

 SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Entitlements work center.
  2. Go to Registered Products view.
  3. Show All Registered Products via drop-down and find ID:XYZ (i.e. XYZ refers to a registered product ID)
  4. Edit and under section: Warranty Assignment
  5. You find that system has not updated the Warranty Details as per Reference Product ID: ABC

Cause

Inbound Delivery Notification and Inbound Delivery creation doesn't assign a warranty from the reference product's warranty data automatically. User can assign a warranty manually for the relevant Registered Product.

Resolution

  1. Go to the Service Entitlements work center.
  2. Go to Registered Products view.
  3. Show All Registered Products via drop-down and find ID:XYZ (i.e. XYZ refers to a registered product ID)
  4. Edit and under section: Warranty Assignment
  5. Update Warranty Assignment details manually for registered product ID:XYZ (i.e. XYZ refers to a registered product ID)

      This is an expected system behavior.

Keywords

Registered Product, Warranty, Reference Product Warranty, Start Date, end date, Reference product, Warranty Assignment , KBA , registered product , warranty , reference product warranty , start date, , end date , reference product , warranty assignment , AP-IDP-ID , Inbound Delivery , Problem

Product

SAP Business ByDesign all versions