SAP Knowledge Base Article - Public

3070390 - Business User View not Assigned to User Through Business Role

Symptom

After assigning a business role which contains the Administrator -> Business Users view to a user, this view is not assigned to the user work center assignments.

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Customer Addons

Reproducing the Issue

  1. Create a business role with access to the Administrator -> Business Users view.
  2. Go to Administrator work center, Business Users view.
  3. Select a user, click on Edit -> Access Rights and assign the business role created in step 1.
  4. Go back to the users list, select the same user and click on Actions -> Update Access Rights -> Selected User(s).
  5. Edit the Access Rights of the user again, and go to the Work Center and View Assignments tab.
  6. Search for the view Administrator -> Business Users.
  7. Here it is possible to see that the view is not assigned to the user.

Cause

When using the Business Users view with restriction rule "1 - Sales Organization of Employee" in the business role, the system needs the respective business user to be assigned in the organizational structure and have a Sales Organization up the hierarchy for the respective employee. If the sales organization of the employee cannot be determined, the work center view is not assigned.

Resolution

 The system works as expected.

Keywords

Administration, Access Restrictions , KBA , business users view to a user , administrator , SRD-CC-IAM , Identity & Access Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions