Symptom
On a Follow-Up Service Order, you notice that after changing the Account, the system did not redetermine the Discounts for them items in the document.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Orders work center.
- Open the Service Order Processing view.
- Find Service Order ABC (Where ABC Represents the Service Order ID).
- Select it and Click on Follow-Up > Service Order.
- In the new document screen, click on View All.
- Navigate to the Pricing and Invoicing tab.
- You will see that a Discount is maintained.
- Now, navigate to the General tab.
- Change the Account to a different one.
- Navigate back to the Pricing and Invoicing tab.
You expect to see a new Discount determined based on the new Account, however, the old Discount remains the same.
Cause
This happens when a Manual Discount is maintained in the document alongside the one determined based on the Account.Due to this when account is changed, the redetermined discount is not applied since there is already a Manual change in the scenario.
Resolution
In order to avoid this, please follow these steps:
- Go to the Service Orders work center.
- Open the Service Order Processing view.
- Find Service Order ABC (Where ABC Represents the Service Order ID).
- Select it and Click on Follow-Up > Service Order.
- In the new document screen, click on View All.
- Navigate to the Pricing and Invoicing tab.
- Remove the discount which has the "Manually Added/Changed" Checkbox marked.
- Now you can change the Account.
The system will be able to redetermine the Discounts as expected.
Keywords
Discount, Determination, Service Order, Sales Order, Manual, Automatic, Follow Up, FollowUp , KBA , AP-SVO-SO , Service Order , How To