Symptom
Certain Users have issues accessing the Data Replication Monitor. When accessing, they are thrown the following error:
"The data could not be fetched. Please try refreshing the browser page. If the problem persists, contact your system administrator."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SuccessFactors
- Data Replication Monitor
Reproducing the Issue
- Login to SuccessFactors as affected user
- Navigate to Data Replication Monitor
- Error appears
Cause
There can be two possible causes for this error:
If we reproduce the issue with F12 developer logs on view, we can see the possible errors associated with the above screenshot:
Possible Error 1:
- "en-US", "value" : "User xxxxxxx doesn't have the 'Employee Central Foundation API' access permission for FOLocation"
- Cause: The new Data Replication monitor is based of OData API permissions - and all necessary permissions would not be maintained.
Possible Error 2:
- "lang" : "en-US", "value" : "Properties EmployeeDataReplicationElement/personNav are not accessible. Please check the property name in Admin Center > OData API Data Dictionary or entity metadata."
- Cause: The metadata is outdated
Resolution
Resolution for Error 1:
- Ensure correct permissions are maintained.
- Under User Permissions, select the Employee Central Effective Dated Entities category.
- Under Job Information, select the View Current option for these fields:
- Company
- Country
- Location
- Employee Class
- Pay Group
Review the handbook LINK for complete list of permissions.
Resolution for Error 2:
- Perform a OData API Metadata Refresh
- Note: The refresh will have no impact on your system - see KBA: 2171588 - OData API Metadata Refresh and Export in SuccessFactors Cloud
See Also
2907140 - New Data Replication Monitor - 1H 2021 release - SAP SuccessFactors
2989939 - Data Replication Monitor produces error 'Data could not be fetched' while filtering by payGroup
3085067 - Users cannot access Data Replication Monitor (screen stuck loading) after all permissions are granted - SAP SuccessFactors HXM S
Handbook link - Employee Central Data Replication Monitor
Blog posting - new Data Replication Monitor
Keywords
Data Replication Monitor, The data could not be fetched, access permission for FOLocation, access, permission, DRM 2.0, EmployeeDataReplicationElement/personNav are not accessible. , KBA , LOD-SF-INT-DRM , Data Replication Monitor , LOD-SF-INT , Integrations , How To