SAP Knowledge Base Article - Public

3071525 - Following Error Occurs in a Contract for an Item: Invoice Schedule Item Start Date XX.XX.XXXX is Greater Than End Date YY.YY.YYYY

Symptom

The following error occurs in a Contract for an item even though the invoice schedule of the item is within the start and end date:

Item XX: Invoice schedule item start date XX.XX.XXXX  is greater than end date YY.YY.YYYY

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center. 
  2. Select the Contracts view. 
  3. Open Contract XYZ (XYZ represents the Contract ID).
  4. The following error occurs:
  5. Item XX: Invoice schedule item start date XX.XX.XXXX  is greater than end date YY.YY.YYYY (XX represents the line item number, XX.XX.XXXX represents the contract item start date; YY.YY.YYYY represents the contract item end date).
  6. Navigate to the Pricing and Invoicing tab and the Invoice Schedule sub tab. 
  7. You can see that the end date in the Invoice Schedule maintained for Line Item XX is not correctly calculated.

Cause

There is no value in the recurrence for the field Every of the Invoicing Time Frame in your Invoice Schedule maintained.

Resolution

  1. Go to the Sales Orders work center. 
  2. Select the Contracts view. 
  3. Open Contract XYZ (XYZ represents the Contract ID).
  4. Navigate to the Pricing and Invoicing tab and the Invoice Schedule sub tab. 
  5. Click on the Edit Invoicing Time Frame button. 
  6. Select the Invoicing Time Frames assigned to Line Item XX. 
  7. You can see in the Recurrence Pattern that for the field Every, there is no value maintained.

You need to ensure that you enter a value in the field Every of the Invoicing Time Frame in your Invoice Schedule for example Every 1 Year(s)

Keywords

Start Date; Invoice Schedule; End Date; Invoicing Time Frames; Recurrence; Every , KBA , AP-CCP-CC , Customer Contract , Problem

Product

SAP Business ByDesign 2105