SAP Knowledge Base Article - Public

3072226 - Business Role activation failed in the target C4C system

Symptom

  • Activation Failed error messages for few Business Roles in the transport logs
  • For example:
    • Failed to create business role XYZ
    • Failed to activate business role XYZ
    • Work center view ADMIN_IND_SETTINGS is no longer scoped Transport Object ID:ZXX:XX:XXXX:SECURITY
    • Assigning view ADMIN_IND_SETTINGS together with work center SEODADMINWCF not permitted Transport Object :ZXX:XX:XXXX:SECURITY
      (where the XX value is a variable and the ADMIN_IND_SETTINGS could also be some other value)
  • Some of the roles we are able to transport successfully

Environment

  • SAP Business ByDesign
  • SAP Cloud for Customer
  • SAP C4C CORE 2105 / 804

Reproducing the Issue

  1. Connect to the target tenant system
  2. Go to Administrator-> Transport Management view 
  3. Open the desired transport ID
  4. Go to Transport Logs

Cause

In this example, the target tenant system does not have the scoping enabled for the Industry Solution

Resolution

  1. Connected to the target tenant system
  2. Navigate to the Business Configuration Projects view
  3. Select "Edit Scope"
  4. Go to step 3: Scoping
  5. Make sure that the Industry Solution box is checked
  6. Hit next until the scoping is finished

Keywords

Activation failed UTM transport management activation error transport request error, missing scoping in the target system, missing view in the target system , KBA , LOD-LE-UTM , Unified Transport Management , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2105 ; SAP Cloud for Customer core applications all versions