SAP Knowledge Base Article - Public

3073634 - Payment Information missing in Personal Data Collection - Onboarding

Symptom

  • Payment information portlet (direct deposit) is not available for the candidate to enter their information.
  • Bank Details in Payment Information portlet is missing in PDC step

Environment

SAP Successfactors Onboarding

Reproducing the Issue

  1. Login as candidate
  2. Open PDC tile
  3. Click Continue until Payment Information Portlet
  4. Payment Information bank details is not available

Cause

  • Cause 1: There is no "Personal Information Screen Lookup" configured for Payment Information hence the compensation portlet didn't show any payment information.
  • Cause 2: onboardingExternalUser has missing permission for country/regions

Resolution

Solution 1: Need to add Personal Information Screen Lookup for Payment Information.

  1. Go to Manage Data
  2. Click Create New
  3. Search for Personal Information Screen Lookup
  4. Select Payment Information as Object Type
  5. Then select screenID from the dropdown.

Admin Guide: Setting Up the Configuration UI

Solution 2: Grant country/region (e.g. cust_PaymentInformationDetailV3CAN) permission under Miscellaneous Category for onboardingExternalUser role

See Also

Keywords

obx, Payment Information, Bank Details, Compensation, Personal Data Collection, Custom Data Collection, Payment information missing, country specific payment  , KBA , LOD-SF-OBX-DC , Personal Data Collection , Problem

Product

SAP SuccessFactors Onboarding all versions