Symptom
- Payment information portlet (direct deposit) is not available for the candidate to enter their information.
- Bank Details in Payment Information portlet is missing in PDC step
Environment
SAP Successfactors Onboarding
Reproducing the Issue
- Login as candidate
- Open PDC tile
- Click Continue until Payment Information Portlet
- Payment Information bank details is not available
Cause
- Cause 1: There is no "Personal Information Screen Lookup" configured for Payment Information hence the compensation portlet didn't show any payment information.
- Cause 2: onboardingExternalUser has missing permission for country/regions
Resolution
Solution 1: Need to add Personal Information Screen Lookup for Payment Information.
- Go to Manage Data
- Click Create New
- Search for Personal Information Screen Lookup
- Select Payment Information as Object Type
- Then select screenID from the dropdown.
Admin Guide: Setting Up the Configuration UI
Solution 2: Grant country/region (e.g. cust_PaymentInformationDetailV3CAN) permission under Miscellaneous Category for onboardingExternalUser role
See Also
- Setting Up the Configuration UI
- 2477238 - How to add new Country Specific configuration to Payment Information Detail object
Keywords
obx, Payment Information, Bank Details, Compensation, Personal Data Collection, Custom Data Collection, Payment information missing, country specific payment , KBA , LOD-SF-OBX-DC , Personal Data Collection , Problem
Product
SAP SuccessFactors Onboarding all versions