SAP Knowledge Base Article - Public

3073861 - Unable to set field visibility using business rules - Employee Central

Symptom

Field A is set to invisible by an onView rule in a portlet.

Editing Field B in the same portlet should make Field A visible due to an onChange rule under Field B, however Field A is still invisible.

How to set the visibility of Field A if it is not visible while editing?

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. There is an onView rule in jobInfo portlet to set field A invisible
  2. Go to People Profile page
  3. Insert a new record to change field B value
  4. Field A should appear due to an onChange rule under field B
  5. However, field A does not show up

Cause

This works by design. Currently, it is not supported to change a field's visibility if the field is not visible when editing.

Even though it is saying that the rule executed successfully in the rule trace log, onChange rule will not set the field to be visible if the field is not visible before value change. 

Resolution

Please remove the onView rule which makes field A invisible, or at least set the visibility to be view.

Keywords

onView, onChange, visibility, business rule , KBA , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions