SAP Knowledge Base Article - Public

3074432 - How To Use Category Mapper In Ticket Categorization

Symptom

After training a new model for ticket categorization you notice that some cases are being mapped with categories from an old category catalog.

Environment

  • SAP Cloud for Customer

Reproducing the Issue

  1. Open a ticket that has been categorized and check the category.
  2. Check is this category is present in the current category catalog.

Cause

When you create a new Ticket Categorization model, train it and make it active, it would have taken the Service Catalog and Categories present in the Service Catalog active at that time for training the model, and further predicting the categories in Ticket.

Now, when the Service Catalog validity ends, some of the older categories present in the previous Catalog may not be relevant anymore in the new Catalog. However, the model was trained with the older Catalog and categories - hence the model may still use the older categories for prediction.

This would not be correct, as those older categories is not even relevant and not present in the new catalog.

Resolution

The category mapper file is designed for this exact use-case, and is used to map newer categories from the new Service Catalog to the ones present in the trained model that are not valid anymore.

Hence, the purpose of the category mapper file upload is to ensure that the older categories not present in the current active catalog are removed for model training, and replaced with what is provided in the "Mapped Category ID" column of the category mapper file.

See Also

Help Documentation

Keywords

category, mapper, ticket, model, machine learning, categorization, service, active category,mapper,file,machine learning,ticket,categorization,service , KBA , LOD-CRM-ML-SRV , Machine learning for service cloud , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions