SAP Knowledge Base Article - Public

3075474 - Impossible to post timesheet entries through the API to inactive employees during their previously time

Symptom

When trying to post entries to an employee which is inactive, during the time they were active, get the error informing that Personnel number does not exist or customer does not have the authorization.

For example:

The employment of the employee ended in december 2020, you try to post timesheet for july 2020. Still you get an error message informing htat the Personnel number does not exist or you do not have authorization.

 

Environment

SAP S/4HANA Cloud 2105.

Reproducing the Issue

Send an API call for an inactive employee during its active time.

Cause

This is a bug in the system.

Resolution

This issue will be fixed in release SAP S/4HANA Cloud 2108.

Keywords

inactive, posting, time sheet. , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem

Product

SAP S/4HANA Cloud 2105