SAP Knowledge Base Article - Public

3075523 - Ticket Created via Email has Empty Description

Symptom

You noticed that some Tickets created via email has an empty Description.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Select the Tickets view.
  3. Open Ticket ID 123 (123 represents the ID of a Ticket you noticed has no Description).
  4. See the Description is empty.
  5. Go to the Interactions facet.
  6. You see the first interaction, the one that is copied to the description, shows an Internal Note with "[This message has no content]".

Cause

This happens due the way the e-mail is sent. On the MIME of the e-mail, the attribute "text/plain" is empty.

Resolution

This is the attribute the application uses to create the Ticket Description from the E-mail. If you have content on other attributes, for example "text/html", you will have the e-mail content on the Interactions and this will work, but the description comes from the "text/plain".

Currently, this is the expected behavior. The description will only be taken from the "text/plain" and if it is empty, the description will also be.

An alternative option may be to check the SAP Cloud for Customer Influence Site to submit an idea.

Keywords

email ; channel ; work description ; text ; content ; mime type ; , KBA , LOD-CRM-SC-EML , Email , How To

Product

SAP Cloud for Customer core applications all versions