Symptom
You are trying to create a time item from time entries, and observe the error message:
Product for time entry: XXXX not determined. Check Determination Rules.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service work center
- Go to Tickets view
- Navigate to Time Entries tab
- Select any line item
- Click on the More button and select "Create Time Item(s)"
- Click on ok in the popup window.
- Error "Product for time entry: XXXX not determined. Check Determination Rules." is raised
Cause
The Product is not maintained in the Product Determination Rules for Time entry against the Time types and just a * (asterisk) is maintained under the Product column.
If the scoping question - "Do you want to enable rule-based product determination for a Ticket from Time Recording", is enabled, the the Product needs to be maintained in the Product Determination rule table.
Resolution
- Go to Administrator → Service and Social → Define Rules for Time Item Product
- Edit the Product column and maintain the Product ID(s)
- Click on Save and activate the rule
The determination rule will now work and you can successfully create time items.
See Also
Keywords
time item, time entry, determination, product, item, ticket, rule , KBA , time , item , ticket , determination , product , entry , LOD-CRM-SRP-CSI , Integration of service ticket with Core systems , LOD-CRM-SRP , Service Request Processing , Problem