Symptom
When trying to update or insert values in a field through Integration Center, the integration fails with error:
"[RCM Entity in use]: UPSERT failed for the row with key: . Reason: [field ID] invalid, . The row will not be processed for subsequent entities"
Environment
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors HCM Suite
Cause
The field in use is a picklist field, and the value being transferred is being sent as a string. Example: the field is using picklist state, and the value being sent is CA.
Resolution
When using picklist fields, the field is a navigation entity. Because of that, it's required to map and use the option ID of the picklist value instead of the label. Since Integration Center runs OData API to obtain the data or update it, the same behavior applies.
If the CSV file used to UPSERT the picklist fields, the value selected always need to be the option ID associated with the id field of the picklist field. Otherwise, the error in the Symptom of this KBA will occur.
See Also
Keywords
picklist, field, jobapplication, jobrequisition, joboffer, candidate, entity, UPSERT failed for the row with key. , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem