Symptom
Multiple email sent from a trigger based campaign at same time.
Environment
SAP Marketing Cloud Edition
Reproducing the Issue
- Create a trigger based campaign and use the created email content for the send email action.
- Upload an interaction or create an interaction to get the campaign triggered.
- Observe that the multiple emails are sent to the same contact.
Cause
The design is depending on the segmentation profile used for the campaign trigger filtration.
Resolution
Make sure to use a segmentation profile using 'interaction key' as key field for the email used in a trigger based campaign. The segmentation profile 'All Interactions' is using segmentation object 'SAP_CE_INTERACTIONS', that uses the interaction key as key field.
With using the interaction key as a key field, the data is filtrated and retrieved from the source interaction of the trigger based campaign. Using any different segmentation profile that is based on the contact key/ consumer key, the data is retrieved on contact /consumer level, hence the email is sent multiple times as there are multiple interactions are created at contact/consumer level.
See Also
2764367 - SAP Marketing - Email sent from Trigger Campaign not filled with Attributes from Source Interaction
Keywords
Trigger Based Campaign, Email, All Interactions, multiple email sent email sent twice, subscription
Segmentation Configuration, Segmentation Profile, Segmentation Object, Key Fields, CUAN_INTERACTION, Interaction Key , KBA , CEC-MKT-CPG , Campaign , Problem