Symptom
When you replicate a sales order from ERP, you found the item type Z123 is changed to another one in C4C sales order, although in the payload, the item type is still Z123 (Z123 represents the item type ID maintained in business configuration).
Environment
SAP Cloud for Customer
Reproducing the Issue
From the payload, you found for the relevant item, the item type is Z123.
Open the Sales Order in C4C, Navigate to Products tab and check the item, you found the item type is another one.
Cause
The item type Z123 does not exist in the C4C Sales Order Business Configuration Fine Tune Activity.
Resolution
- Go to the Business Configuration work center.
- Go to the Overview work center view.
- Search for the Fine Tuning Activity: Sales Order and open it
- Click on Maintain Item Types.
- Search for type Z123, you see Z123 is not existing here.
- Add the Z123 here.
Please note: Z123 should not exist in Sales Quote Item Type list. C4C does not allow to create the same item type in Sales quote and Sales order. In case Z123 is used in Sales Quote, you need to create a new one in sales order and use the new item type.
Keywords
Item Type, Sales Order, Sales Quote, Replicate , KBA , LOD-LE-XCR , Cross CRM , LOD-LE-CQP-CO , Lean Sales Orders , Problem
SAP Knowledge Base Article - Public