Symptom
DocuSign email is not sent to a candidate.
In Business Process tile, it shows an error "Envelope could not be sent to DocuSign. Please check your DocuSign settings."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding
Cause
- If the issue is happening to all candidates, it could be caused due to misconfiguration in DocuSign account or incorrect credentials.
- If the issue is happening to some of the candidates, it could be caused due to invalid email address.
Resolution
For the 1st situation - the issue is happening to all candidates:
1. Please ensure that the options below are enabled in DocuSign account.
(1) Allow Sender to set email language for recipients
(2) Enable custom email and language for each recipient
Please note: if you could enable "Enable custom email and language for each recipient", then "Allow Sender to set email language for recipients" has been enabled.
If not, please contact DocuSign company to enable "Allow Sender to set email language for recipients".
2. If the issue still persists although configurations are done correctly, please re-enable the DocuSign feature with the correct credentials in Onboarding.
For the 2nd situation - the issue is happening to some of the candidates:
Please check the email address of the impacted candidate and manager.
Candidate's email address can be found in Dashboard >> New Hire Data.
Manager's email address can be found through Employee Export.
@Support Engineers, please check internal memo for more details.
Keywords
DocuSign, error, signature, form, USER_AUTHENTICATION_FAILED, One or both of Username and Password are invalid, USER_LACKS_RECIPIENTEMAILNOTIFICATION_PERMISSION, Account or user does not have permission to set recipient email notifications, INVALID_EMAIL_ADDRESS_FOR_RECIPIENT, The email address for the recipient is invalid. The recipient Id follows. , KBA , LOD-SF-OBX-DSN , Docusign Integration , Problem