Symptom
- Provisioning Access email triggered by Manage Provisioning Access is not received on partner email;
- Partner is not able to access provisioning as email from Provisioning tool is not received;
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Login with an admin user with access to Manage Provisioning Access;
- Go to Admin Center -> Manage Provisioning Access;
- Click on the '+' sign on the top right;
- Enter your partner email address;
- Partner does not receive the email.
Cause
The instance has Single Recipient enabled and so all emails from the instance are redirected to the Single Recipient.
The instance has Single Sender enabled, so email will not be triggered.
Resolution
You can perform one of the solutions below:
- Disable temporarily the Single Recipient on your instance;
- Go to Admin Center > Manage Email Notifications
- Uncheck the 'Enable Single Recipient' flag
- Click on Save (after this we advise to be careful on what email you trigger on the instance)
- Then you can trigger the Provisioning Access email
- Once the email is received, you can revert the above changes
- Change to the Single Recipient rule to be applied only to some email domains (email domains that you know that are in use on your instance and you do not want emails sent to):
- Go to Admin Center > Manage Email Notifications
- Search for Single Recipient, on field add your partner email domain
- Click on Save (after this we advise to be careful on what email you trigger on the instance)
- Then you can trigger the Provisioning Access email
- Once the email is received, you can either keep this change if you want that emails from your partner domain receive email notifications or disable it, as the best for your project
-> Email sent to end user who's email is XXX@sap.com recipients (SAP colleague)
In the past, we relayed emails with @sap.com recipients directly to the SAP mail gateway will be rejected by SAP mail gateway. However now no the rule is not valid anymore. Means in below scenarios, recpient email is XXX@sap.com can receive SF email as normal:
- recpient email is XXX@sap.com
- customer has enabled Single Sender.
- customer add new provisioner which will send email to the new provisioner; the provisioner is SAP colleague
So as of now, emails to @sap.com are being sent through the internet, to whatever is in the domain’s MX record like any other mail traffic
But still if there are emails that are not delivered to @sap.com then first the sender domain needs to be verify their (A, MX, DKIM, SPF, etc.) , for any further queries or issue log an ticket to Cloud Support team and below is the workaround.
[Workaround]Disable Single Sender temporarily- Go to Admin Center > Manage Email Notifications
- Uncheck the 'Enable Single Sender' flag
- Click on Save
- Then you can trigger the Provisioning Access email
- Once the email is received, you can revert the above changes
NOTE: Starting from 2H 2023 release, Single Sender and Single Recipient have been moved from Provisioning to Manage Email Notifications in Admin Center as a new self-service tool for customer. The existing configuration on Singler Sender and Single Recipient before 2H 2023 release were copied from Provisioning to Manage Email Notifications. Please refer to KBA 2087739 - Single Sender and Single Recipient | How They Work and Setting Them Up in SuccessFactors.
- It is now required to use a verified domain for customized single sender. If you disable it when following the resolution above, to enable it again, the domain owned by the organization would have to be verified as per Adding Verified Domains | SAP Help Portal.
See Also
Keywords
Single Recipient Manage provisioning access emails partner, provisioning access email, provisioning access notification, email notification , KBA , LOD-SF-PLT-PRVR , Manage Provisioning , LOD-SF-PLT-SING , Single Sender and Recipient , Problem