SAP Knowledge Base Article - Public

3079458 - Field Reason is not available in Employee Timesheet

Symptom

When you are trying to book a time entry from Employee Self Services Overview, the field Reason is not available. But, the same field is available in the Time sheet in Time Administrator work center view.

Environment

 SAP Business ByDesign

Reproducing the Issue

  • Go to Time Administrator Work center -> Employee
  • Select an Employee and then Click Edit
  • Go to the Tab Employee Times
  • Click Add Row and then choose the Time Type as Special Leave
  • In the General Tab, you can see the field Reason. 
  • But, the field Reason is not available, When you choose the same Time Type in the Time sheet available in Employee Self Services Overview

Cause

This is a standard Behavior

Resolution

The Reason can be updated only by the Time Administrator in case of Employee's Absence. You can check the same by following the below steps :

  • Go to Business Configuration -> Overview
  • Open the Activity Time Types Germany
  • Click Maintain Employee Time Types in the next screen
  • Open the Time Type DE0050 and then go to Allowed Reasons Tab
  • You can see the explanation, You can assign reasons to time types, which are then available for a time administrator to record against absences in an employee's time file

Keywords

Time Administration, Reason, Employee Time Type, Special Leave , KBA , SRD-HR-TLM , Time and Labour Management , Problem

Product

SAP Business ByDesign all versions