Symptom
EC Alerts are generated for Terminated Subject User and/or sent to Terminated Users
Example: The rule is setup to send an alert in the future for subject user (for example, 5 days before end of contract). If subject user is terminated before alert date, the alert is still created
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central
Reproducing the Issue
Example:
User has a contract end date as of 01/01/2019
an alert rule will generate an alert 2 weeks before the contract end date
User is terminated effective as 31/10/2018 which is before the contract end date
No alert should be sent
Cause
Currently, during record scanning and alert rule evaluation, the records for the terminated subject users (for current terminated users) are included, creating an entry in the Alert table for them. Essentially, the system configures alert jobs based on the user status at the time the job is triggered, rather than when the email is sent.
As a result, terminated users will still receive notifications even after they have been deactivated.
Resolution
If the user will be terminated in the future, after the contract end date, the alert will still be sent. The workaround is to delete those alerts manually via Manage Alerts and Notifications.
Additional Notes:
When alerts reach their designated trigger date and are triggered, the records for users who have been terminated will be excluded from processing. This exclusion applies to users who are terminated after their alert entry has been created but before the alert triggers. In this case, the system recognizes the change in user status. Consequently, the alert for the terminated user is not created, no email notification is sent, and the status of the alert is updated to "complete", indicating that no further action will be taken.
Keywords
Alert, terminated, inactive, AlertForEmploymentInfoWithTerminatedUser, AlertForJobInfoWithTerminatedUser , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem