Symptom
You cannot see the edit icon on any Object Work List.
Environment
SAP Cloud for Customer.
Reproducing the Issue
- Go to e.g. Sales Workcenter.
- On Opportunities view.
- No edit icon.
Cause
Enable Editing in Dataset is not enabled on Company settings.
Resolution
Navigate to:
- Key User Settings.
- Company Setting.
- Select Enable Editing in Dataset.
Once the feature is enabled, you can click the pencil icon in the upper right corner to switch to the edit mode.
The company settings can be defined for Company or Business Role. When performing changes kindly check the company setup and the setup for the business role assigned to the business user
After performing changes in the company setting a browser refresh or re-login will be needed in order to reflect the changes in the UI.
Keywords
Edit OWL, Edit icon, Enable Editing in Dataset.