Symptom
You create or update an account on the Cloud for Customer tenant which is then replicated to S/4HANA via service interface BusinessPartnerSUITEBulkReplicateRequest_In. It is observed that the following error is raised in SRT_MONI transaction:
"CX_SY_SEND_DYNPRO_NO_RECEIVER:An exception with the type CX_AI_APPLICATION_FAULT was raised, but was not handled locally or declared in a RAISING clause..Application Error.Sending of dynpro SAPLBUPA_TAX_CHECK 3000 not possible: There is no connection to a terminal".
Environment
- SAP Cloud for Customer
- SAP S/4 HANA
Reproducing the Issue
- Open the Accounts work centre in Cloud for Customer.
- Select a customer account.
- Click Edit.
- Change data.
- Save.
- Navigate to the Administrator work centre.
- Select Web Service Message Monitoring.
- Verify that the changes made to the customer account has successfully triggered an outbound message.
- Logon to S/4HANA.
- Enter Transaction: SRT_MONI
- Observe the failed inbound message for service interface BusinessPartnerSUITEBulkReplicateRequest_In
- Error message raised: "CX_SY_SEND_DYNPRO_NO_RECEIVER:An exception with the type CX_AI_APPLICATION_FAULT was raised, but was not handled locally or declared in a RAISING clause..Application Error.Sending of dynpro SAPLBUPA_TAX_CHECK 3000 not possible: There is no connection to a terminal".
Cause
The error occurs due to the duplicate tax number check functionality in S4.
Resolution
Please implement SAP Note 3011311.
Keywords
CX_SY_SEND_DYNPRO_NO_RECEIVER BP C4C TAX CHECK , KBA , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LO-MD-BP , Business Partners , How To