Symptom
- When Business Partners are created or updated using the SOAP inbound web service BusinessPartnerSUITEBulkReplicateRequest_In, a confirmation message is successfully triggered and sent to the SAP CPI interface via the outbound web service BusinessPartnerSUITEBulkReplicateConfirmation_Out.
- However, currently only successful messages are visible in the AIF monitor/dashboard, while error messages are not displayed.
Environment
SAP S/4HANA Cloud Public Edition
Cause
This is the standard system behavior.
Resolution
The AIF Message Dashboard is an application that allows users to monitor various interfaces and track errors occurring during processing. However, the AIF runtime cannot determine if there was a business logic error when the technical processing completes successfully. Since this involves an asynchronous outbound call, the system only indicates that the messages were successfully queued or executed.
Keywords
S4_PC, Communication arrangement SAP_COM_0008, outbound, inbound service, BusinessPartnerSUITEBulkReplicateRequest_In, BusinessPartnerSUITEBulkReplicateConfirmation_Out, AIF monitor, Dashboard , KBA , LO-MD-BP-WS , Web Service for Business Partner , Problem
SAP Knowledge Base Article - Public