Symptom
After using the Content Network tool to import courses from an Open Content Network (OCN) vendor, not all the expected information on the Item record is present. There is missing information such as:
- Translations of the Item Title/Description
- Hours such as Credit or CPE
- Other fields in the Item Details section
Environment
SAP SuccessFactors Learning
Cause
The content vendor does not send the information via the API to SuccessFactors Learning or the API does not have the fields present to send the information.
Resolution
To see the list of information sent via the API, please see the OCN Documentation. If the field is not present, the vendor cannot send the information and you must update the field via the admin interface. It should be vetted with your vendor what information they are sending.
If the field such as Description is present to be sent via the API but a specific locale is not present on your system, please reach out to your vendor. The vendor sends the information via the API and SuccessFactors Learning consumes and updates the Item. The vendor might not support a specific locale so they do not send it through the API or the vendor did not initially send it.
If the Item has already been imported into the system, the vendor can always update the Item information via the API and it will be done automatically. If the the Item has not been imported yet, when the Item is imported it will have the latest information that was sent by the vendor.
Note: SAP SuccessFactors cannot trigger a sync with the vendor to receive the new/updated course information. Please contact your vendor as they need to trigger the API from their end for the LMS to receive the new data so it can be updated.
Keywords
ocn, description, locale, update, title, language, change, sf, lms, open, content, network, item, course, details , KBA , LOD-SF-LMS-OCN , Open Content Network , Problem