SAP Knowledge Base Article - Public

3082307 - User Id Generation failed, candidate is not visible on the Onboarding Dashboard - Onboarding

Symptom

Initiate Onboarding for candidate from Recruiting, the candidate is not visible on the Onboarding Dashboard. An user validation error is displayed in the BPE Tile:

"We were unable to generate user id. Check your business rules or field mapping configuration and try again."

"Images/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Initiate Onboarding for the candidate from RCM
  2. Candidate is not available in the Onboarding Dashboard
  3. User Validation error in BPE Tile "We were unable to generate user id. Check your business rules or field mapping configuration and try again."

Cause

It is highly likely due to a data issue.

Cause 1: User Id generation via rule is dependent on the Company Object. If the field "Legal Entity/Company" is associated directly with its Object in Recruit to Hire Data Mapping then we will observe that the rule defined to generate the User Id will fail.

The rule does not recognize the external code of the Legal Entity when we pass the value from Recruiting to Onboarding, because if the object field is mapped in Recruit to Hire Data Mapping, the internal code is sent rather than the external code

Cause 2: An active employee in the system has already used the employee ID generated for the candidate based on the configured sequence.

Cause 3: No service user assigned in Update Process Flows page

For Technical Support: Please check internal notes for the sample logs

Resolution

Perquisites:

How to identify the incorrect data:

  1. Create a rule trace with Service user as the Login user 
  2. You can find the Service user from Update Onboarding and Offboarding Process
  3. Restart the task from Business Process To-do
  4. You will get the rule trace and be able to identiy the incorrect data

Solution 1:

  • Define a custom text field in job requisition template, populate it with external code of the desired Legal-Entity and map it to jobInformation > Company field in Recruit to Hire Data Mapping Tool instead of object field mapped currently from the Recruit-to-Hire Data Mapping Tool

Step 1: Verify the existing mapping in Recruit to Hire Data Mapping Tool if the field "Company/Legal Entity" is associate with "Legal Entity Object (legalEntity_obj)"

Step 2: Go to Manage Templates and chose the desired Job Requisition Template. Kindly create a custom text field in the Job Requisition Template to store the object value internal code that is passed from RCM to ONB.

Step 3: Set a rule to associate the custom field created in the Job Requisition Template to the external code of the Company/Legal Entity

Step 4: Add this rule to the respective Job Requisition in Manage Rules in Recruiting under "Save Rules"

Step 5: Change the field mapping for Company Object under Job Information in Recruit to Hire Data Mapping:

After the above mentioned steps are completed, complete an ODataefresh and then restart the affected candidate from the Business Process Tile.

Solution 2: Modify the User Id generation rule so that userId generated is unique and then restart the affected candidate from the Business Process Tile.

Solution 3:

  1. Navigated to Update Process Flows Page
  2. Selected active user as service user
  3. Click Update
  4. Navigated to Process Variant Manager
  5. Open Custom Onboarding Process Variant
  6. Click Save & Validate
  7. Click Activate
  8. Then need to reinitiate onboarding for candidates initiated with old service user.
  9. Got the process trigger id from the error message in business process to do
  10. Navigate to Manage Data > Process Trigger
  11. Search with ID
  12. Click Take Action > Make Correction
  13. Change Process Initiation Status to Cancelled
  14. Save
  15. Navigate to recruiting
  16. Open the candidate in the job req 3148
  17. Click Take Action
  18. Select Initiate Onboarding button
  19. Onboarding was initiated again and appeared in onboarding dashboard.

See Also

Keywords

We were unable to generate user id. Check your business rules or field mapping configuration and try again., User Id, sequence, rule, user, generation, failed, Onboarding, OBX, 2.0, generateNextEmployeeIDForONB2 with maxTries reached, maxTries reached, GenerateNextEmployeeIDForONB2Impl, service user , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem

Product

SAP SuccessFactors Onboarding all versions

Attachments

image.png
image.png
image.png
image.png
image.png
image.png
image.png
image.png
image.png
image.png