Symptom
When generating the Item Status Report for a certain Item, the report returns blank data. The report is blank even if there is a user who have completed that specific item.
Environment
Reproducing the Issue
- Learning Administration
- Reports
- Item Status (CSV)
- Specify the User and Item on the report filter
- Run the report
- Report is blank
- Confirm that there is a user that have completed that item
Cause
The item ID provided has a hidden character likely the zero width space (ZWSP) appended in the item ID is causing the issue liklely from copy/paste of source when making the item ID or connector file using UTF-8-BOM or other encoding instead of UTF-8.
To identify:
- Run item Search with operator EXACT and should not appear, run again with operator CONTAINS.
- Download search results CSV and open in notepad or similar program.
- Save or Change encoding to ANSII to see hidden character in itemID.
Resolution
Workarounds:
- Execute report with the user instead of itemID and filter after in CSV.
- Engage Professional Services to assist fixing data.
- Customize report filter to use contains in item criteria (see Custom Report resources KBA 2379690)
- Customize report to replace the ZWDP (e.g. where this ZWSP character is seen after hyphens):
- Export the report
- in the filters section of the report query, if it there is a cpnt_id then we need to replace it with REPLACE(cpnt_id, '-', '-')
- Re import the report as a custom report.
Example of the filter:
Actual -
/** and sc.stud_id in [UserSearch]
and (sc.cpnt_typ_id, sc.cpnt_id, sc.rev_dte) in [ItemSearch]
*/
Fix -
/** and sc.stud_id in [UserSearch]
and (sc.cpnt_typ_id, REPLACE(sc.cpnt_id, '-', '-'), sc.rev_dte) in [ItemSearch]
*/
NOTE: We are currently working with Product Management for a better solution.
Keywords
Item Status (CSV) blank, Item Status Report blank , KBA , LOD-SF-LMS-REP , Reporting Data , Problem