Symptom
Dropdown filter of the processing code on ticket item level only provides two processing type codes.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Open ticket.
- Go to items.
- Add item manually (no parent item is set).
- Select General Data.
- Select field Processing dropdown.
Note: Multiple options available in dropdown.
- Add a parent item.
- Click Enter.
- Select General Data.
- Select field Processing dropdown.
Note: Only two options available in dropdown.
Cause
When an Item has Parent item (main Item) maintained, Processing Type dropdown only shows the Processing Type Code which are relevant for sub-items (Part Consumption, Time, Part Return etc) and all Processing Codes relevant for Main item do not come in the dropdown.
This is the reason you are seeing different list of Processing Codes after maintaining Parent Item.
- For Main Items, dropdown does not provide Processing Code relevant for subitems.
- For Subitems, dropdown does not provide Processing Code relevant for main items.
Resolution
This is system expected behavior.
Keywords
processing code, subitems, parent item , KBA , LOD-CRM-SRP , Service Request Processing , Problem