Symptom
- You are upserting FOCostCenter entity via Integration Center "Scheduled CSV Input Integration" from SFTP to SF.
- You have some problems in the logs files similar like this
"Integration Process Warning","WARNING","2022-FEB-02 22:22:22","FOCostCenter: UPSERT failed for the row with key: FOCostCenter/externalCode="XXX", FOCostCenter/startDate="1990-01-01T00:00:00.000+01:00. Reason: Invalid reference '(effectiveStartDate=null, externalCode=XXX)' for valid when association 'cust_toLegalEntity'.. The row will not be processed for subsequent entities",""
- You also noticed that here are other records not properly imported/updated even if they are not highlighted in the issue log
Environment
- SAP SuccessFactors HCM suite
- Integration center
Reproducing the Issue
Steps to replicate issue:
- Create a simple input Integration Center job
- Run the job to upsert data for FOCostCenter entity
- Notice that the job finished but with errors"
- Checking the log file you can see similar errors like mentioned above
Cause
Integration Center uses $Batch for upsert calls. In batch upsert, if one record upsert failed other records would also be reverted even though they pass the validation. These records will not be properly imported and logged as error in the log file.
"Upsert operations in a $batch ChangeSet follow the "all-or-nothing" rule. That means, if one record fails to upsert, all other changes will roll back."
Resolution
To avoid this situation you need to be sure that data in the csv import file is maintained correctly. (No mismatch in the file, missing/incorrect values, values which are not exist on SF side, etc...)
You need to fix each known issue one by one from the log file until the job finishes Successfully without errors.
See Also
Keywords