SAP Knowledge Base Article - Public

3085492 - Sales Order (A2A) API not working for One-Time Customer

Symptom

When trying to create a sales order for a one-time customer (CPD) using the A2A Soap API SalesOrderBulkRequest_In for sales orders due the following error message is raised:

Address data of one-time customer * is incomplete.

"Image/data in this document is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP S/4HANA Cloud

Reproducing the Issue

Although the necessary address data is provided  in the request, an error message is displayed and it is not possible to create the sales order:

Error message at Message Dashboard app:

Cause

  • The system is checking the relevant BP master data address.
  • This is the standard system behavior.

Resolution

In order to overcome this error message and create the sales order, maintain the relevant address data for the respective customer at the customer master data.

Go to Manage Customer Master Data -> Address tab

Note: The necessary address data must always be provided in the request for the respective one-time customer. Otherwise, the error message will be raised.

See Also

SAP Help Documentation - Sales Order (A2A)

Operations for Sales Order (A2X)

Keywords

one time customer, one-time customer, CPD, A2A SOAP API, 013(SLS_LORD), 013, Sales Order (A2A), A2A, SalesOrderBulkRequest_In, onetime customer, customer account group, , KBA , SD-SLS-API , API , SD-SLS-API-2CL , API (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions