Symptom
When creating a sales order for a one-time customer (CPD) using the A2A SOAP API SalesOrderBulkRequest_In, the following error message is raised: Address data of one-time customer * is incomplete.
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Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Although the necessary address data is provided in the request, an error message is displayed and it is not possible to create the sales order:
Error message in the "Message Dashboard" app:
Cause
- The system is checking the relevant BP master data address.
- This is the standard system behavior.
Resolution
In order to overcome this error message and create the sales order, maintain the relevant address data for the respective customer at the customer master data, by going to the "Address" tab of the "Manage Customer Master Data" app.
Note: The necessary address data must always be provided in the request for the respective one-time customer. Otherwise, the error message will be raised.
See Also
Keywords
one time customer, one-time customer, CPD, A2A SOAP API, 013(SLS_LORD), 013, Sales Order (A2A), A2A, SalesOrderBulkRequest_In, customer account group, , KBA , SD-SLS-API , API , SD-SLS-API-2CL , API (Public Cloud) , How To
Product
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