Symptom
When trying to set up the credentials for Exchange Online, the below errors are appeared:
The system failed to connect to Exchange Online for one of the reasons below. Please correct the following errors:
1. Invalid Client ID, Client Secret, or Tenant ID.
2. Service Principal Name (SPN)'s Client Secret may be expired.
3. Service Account's email address is invalid or doesn't exist in the system.
4. Try again later.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
1. Log in to BizX
2. Go to Interview Scheduling and Outlook Integration
3. Key in the credentials you have registered from Azure portal.
4. Click Verify Connection to establish the Outlook Integration for Interview Scheduling
5 Error will show:
The system failed to connect to Exchange Online for one of the reasons below. Please correct the following errors:
1. Invalid Client ID, Client Secret, or Tenant ID.
2. Service Principal Name (SPN)'s Client Secret may be expired.
3. Service Account's email address is invalid or doesn't exist in the system.
4. Try again later.
Cause
Based on Splunk Logs:
Caused by: com.microsoft.graph.http.GraphServiceException: Error code: NoPermissionsInAccessToken Error message: The token contains no permissions, or permissions can not be understood.
Microsoft Graph API permissions were not granted.
Resolution
Delegated and Application Permissions on the Microsoft Graph API are needed to be granted. If these permissions were not enabled from the Azure Portal, the integration will not work.
Delegated permissions
Calendars: Calendars.Read.Shared and Calendars.ReadWrite.Shared
Application permissions
Calendars: Calendars.Read and Calendars.ReadWrite
Mail: Mail.Send
Please see Technical Details for Interview Scheduling Outlook Integration Using Modern Authentication for the full information about the needed permissions.
See Also
Keywords
Interview Scheduling Outlook Integration, Verify connection, Modern Authentication , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem