Symptom
Territory ID cannot be updated via Data Workbench.
Environment
SAP Cloud for Customer
Cause
It is not possible to update the field "territory_id" within the entity "Sales Territory Account". This is due to technical reasons. (account is a subnode on BO SalesTerritory).
Odata metadata for SalesTerritoryAccount the field TerritoryID is marked as 'updatable=false' due this.
Resolution
If you want to assign an existing account to a new/different territory then you have to delete the existing assignment and create a new assignment.
On Data Workbench you'll need to choose "Individual Object" and then "Update" and provide the deletion and creation in one file. (Do this if the total amount of records is not too big, else it is recommended to first maintain a file containing the deletion and then a new separate file with a re-creation).
Within the file add a column "ToBeDeleted" and mark the records with "TRUE" and maintain "Territory_id" and "Customer_ID" for the new assignment.
See Also
2604853 - You Cannot Delete A Territory 'Cannot Delete Territory; * Remain Assigned To It'.
2765150 - Sales Territory Cannot be Deleted Using Data Workbench
2735885 - How to Remove Territory from Account Using Data Workbench
2699948 - During a Territory Cleanse You Are Faced With an Error Message : "Territory can not be deleted; transaction documents are using territory " And the Action Cannot be Completed
Keywords
Delete Territory, Data Workbench, Account, Territory, Update , KBA , LOD-CRM-TM , Territory Management , How To