Symptom
Within the Customer Merge window, in the Attribute Selection, you are not able to edit specific rows to be visible or not via Adaptation mode.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customer Merge work centre.
- Open any entry.
- Enter Adaptation Mode.
- Go to, and select the Attribute Selection.
- Try to select one row for editing
Result: while you can hide/unhide the columns themselves (Element, or similar) you cannot set particular row of entries as invisible (KUT field, or standard).
Cause
The rows you see are automatically pulled from the Customer Master Data (customer/ individual customer object). If a relevant field has an entry within the master data object (Customer/ Individual Customer), it will show up here as row.
This is also the case, if the field has an entry/ value, but is hidden in the object UI itself.
Resolution
This is expected system behaviour by design as the entries are taken from the master data.
See Also
SAP Help Portal: Customer Merge
Keywords
Attribute Selection, Administration, Edit, Row, KUT , KBA , LOD-CRM-ACC , Account , How To