SAP Knowledge Base Article - Public

3087206 - "Process exceeded maximum execution time limit" error - Boomi

Symptom

You are receiving the error "Process exceeded maximum execution time limit" in Boomi for process execution while calling some SuccessFactors endpoint.

Environment

SAP SuccessFactors HXM Suite

Boomi

Reproducing the Issue

  1. Run the Boomi process;
  2. See the error message under Manage > Process Reporting;

Cause

The Atom execution time limit was reached. The maximum execution time for SAP-hosted Atoms is 5 minutes.

There are many possible causes for processes take longer than the expected. 

Downloading the Boomi logs (Under Manage > Process Reporting > paper icon) and searching for "caused by" keywords, you can have an idea of the cause.

Some of them are:

  1. High data volume or inefficient Boomi process settings;
  2. API endpoint issues;

Resolution

Regarding cause 1:

The listener process is not meant for high data volume or complex process where execution time might exceed 5 minutes.

The possible solutions for processing high data volume are:

  • Use Atom queue connector based on these Boomi blogs (link1 link2);
  • Use scheduled process to avoid this time limit, which means switching over from listener to general mode;
  • Running the process in low latency mode (refer to this link);

If your Boomi process is not editable as it is standard (SAP-provided), we recommend you to raise a ticket to LOD-SF-INT-BOM team so they can do the necessary adjustments for you.

Regarding cause 2:

For SuccessFactors API endpoint issues such as "Connection timed out" and "Internal Server Error", we recommend you to raise a ticket to LOD-SF-INT-API team so they can investigate the cause further.

Keywords

listen, listener, atom, queue, SF, hosted, cloud, connection timed out, timeout, atom, atoms , KBA , LOD-SF-INT-BOM , Standard SF to 3rd Party Boomi Content , LOD-SF-INT-CUS , SF Boomi & CPI (HCI) Custom Content , Problem

Product

SAP SuccessFactors HCM Suite all versions