Symptom
Open Content Network Content Synchronization completed with errors:
I/O error on GET request for "https://api-1.lynda.com/delta": Connect to api-1.lynda.com:443 [api-1.lynda.com/8.39.42.103] failed: connect timed out (local port [port] to address [IP address] ([servername]), remote port 443 to address 8.39.42.103 (api-1.lynda.com)).
Environment
SAP SuccessFactors Learning
Cause
This is caused due to issues on the OCN vendor side connection no longer being accessible.
Resolution
LinkedIn Learning no longer utilizes the Lynda API endpoint. To disable Lynda integration:
- Go to System Administration > Configuration > System Configuration
- Edit OPEN CONTENT NETWORK
- Change providers[LYNDA].enabled to false
- Apply Changes
Afterwards all Lynda courses can be disabled by going to Content > Activate/Deactiviate OCN Courses. This should be done if the Lynda content is no longer accessible or unsupported. You should validate with LinkedIn Learning if the Lynda OCN courses should be deactivated if there is a LinkedIn counterpart.
Keywords
sap, sf, success, factors, successfactors, learning, lms, ocn, open, content, network, lynda, linkedin, linked, in, course, duplicate, sync, synchronization, error, i/o, io, connection, timeout, connect, timed, out , KBA , LOD-SF-LMS-OCN , Open Content Network , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ADM , System Admin, Global Variables, References , Problem