SAP Knowledge Base Article - Public

3089495 - Business Partner Integration Between C4C & S/4HANA Creates the Business Partner With a Different Number

Symptom

When replicating C4C Accounts to S/4HANA, the Business Partner is created in a different number than it is in C4C. The requirement is to have the S4 Business Partner created in a specific custom number range.

Environment

  • SAP Cloud For Customer
  • SAP S/4HANA

Cause

  • In the standard C4C-S/4HANA Integration, when creating an account in C4C and replicating it to S/4, the tag <NumberRangeIntervalBusinessPartnerGroupCode> is not populated in the C4C generated BP payload (BusinessPartnerSUITEBulkReplicateRequest). This tag is also not populated in the SAP Standard delivered CPI/PI mapping.
  • Whenever the C4C account data is received by S/4 BP interface BusinessPartnerRelationshipSUITEBulkReplicateRequest_In, the BP number range is determined automatically using the BP internal standard default grouping (standard setup is 0001).

Resolution

The XML tag <NumberRangeIntervalBusinessPartnerGroupCode> should be updated in the CPI iflow via custom mapping.

The implementation steps are available in the following blog:

SAP Cloud For Customer and S/4HANA Business Partner Integration – Creating BPs using a specific group number range

A sample custom CPI post-exit iflow is attached to this KBA, which can be used as a reference.

Please note: SAP Product Support cannot provide support for issues or problems which are experienced using custom CPI integration iflows (consulting). 

Keywords

BP, C4C number range, S4 account group , KBA , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To

Product

SAP Cloud for Customer core applications all versions

Attachments

Replicate Business Partner to S4 - PostExit.zip