SAP Knowledge Base Article - Public

3089579 - Special Characters Are Not Shown In SMS

Symptom

You have created an SMS campaign, but you found out that special characters such as ç, ê, ë and ô, commonly used in French, are not visible in the SMS text when contacts receives SMS campaigns.

Environment

SAP Marketing Cloud Edition
SAP Marketing On-Premise from Release 1709 SP01

Reproducing the Issue

  1.  Create a Text Message containing special characters such as ç, ê, ë and ô, commonly used in French, in the Content Studio app.
  2.  Send a SMS campaign with the create Text Message content.
  3.  Some contacts which received the SMS cannot see the special characters in the SMS.

Cause

There is no code in SAP Marketing Cloud application to handle this scenario.


Resolution

This means that nothing from SAP Marketing side can be done regarding this scenario, as we don’t have any influence on the behavior of the receiving device.

 

The configurations to handle special characters must be in mobile devices side.

Keywords

Text Message, SMS, Special Characters  , KBA , CEC-MKT-MEM , Content Studio: E-Mails and other messages , How To

Product

SAP S/4HANA Cloud 2108