Symptom
vendorOrderNo is no longer being recognized when Xref are sending status updates back to SuccessFactors.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to OData API Audit Log Detail
- Select Entity JobApplicationBackgroundCheckResult
- Response Payload: The vendorOrderNo XXX is not valid for vendorCode xref. with the index 0</message></error>.
Cause
The vendorOrderNo is null for all the background check request.
Resolution
The way that the Background Check works in SuccessFactors is that the information that is inserted into the JobApplicationBackgroundCheckResult is always validated against the JobApplicationBackgroundCheckRequest and as the error that is being returned back to them when they try to insert into the Result entity the system is trying to find the same information on the Request and there are no vendorOrderNo matching the request sent.
Now, the Vendor Order Number (vendorOrderNo) is a value that is generated by the Vendor. When you trigger the Background Check we send the request, and as part of the process on the Vendor side is to update SuccessFactors with what we call the "Acknowledgement", and on that step they update the JobApplicationBackgroundCheckRequest entity with the vendorOrderNo, which is the order number for the background request on the vendor side. So by the time they execute the whole background check and start updating the Results on JobApplicationBackgroundCheckResult the vendroOrderNo is already present on the request, so the system can validate the Vendor Code and the Order Number and update the Results entity.
Therefore if you are facing the above issue the problem is on the vendor side. Please reach out to them.
See Also
2845873 - How Background Check Integration Works (Integration Center) - Recruiting Management
Integrating Recruiting with Other Third-Party Vendors for Background Checks
Keywords
vendorOrderNo, vendorCode, null, background check, xref, message, error , KBA , LOD-SF-RCM-BCI , Background Check , Problem