Symptom
The API API_MKT_INTERACTION_SRV is being used to import EMAIL_BOUNCE_HARD and EMAIL_BOUNCE_SOFT interactions. After these bounce interactions are imported, you navigate to the respective campaign and check its performance tab. The Performance tab is not showing the bounce data.
Environment
SAP Marketing Cloud
Cause
The API API_MKT_INTERACTION_SRV only support the import of inbound interactions. The interaction types EMAIL_BOUNCE_HARD and EMAIL_BOUNCE_SOFT are considered outbound interactions and therefore the import via API_MKT_INTERACTION_SRV is not completely functional.
Also, regarding the Campaign Performance tab, system will filter out all interactions that do not have a certain parameter filled. This parameter is the Execution Run Key of the campaign and it cannot be filled by the API API_MKT_INTERACTION_SRV.
Resolution
This scenario is more relevant for integration with ESPs that are setup using the Generic Email Interface. You must setup the Get Bounces method of the Generic Email Interface to be able to work with bounces from this provider.
The correct setup of Get Bounces method will also ensure a correct measure of campaign performance, as the Email Outbound interaction is substituted by the Bounce interactions in such cases.
See Also
Keywords
generic email interface, esp, email service provider , KBA , CEC-MKT-CPG-EXE , Campaign execution , CEC-MKT-CPG-SUC , Campaign Success/Performance , CEC-MKT-DM-IA , Interaction , How To