SAP Knowledge Base Article - Public

3090887 - Reminder Notification is not working appropriately - Onboarding

Symptom

Reminder Notification not triggered appropriately according to the Set Up Reminder configuration from Email Services.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Configured Set Up Reminder> Ser reminder before the due date
  2. Set up "Frequency of reminders in days"=1, "Number of reminders to be sent"=5
  3. For some candidates, Reminder Notification not triggered, and for other candidates, Reminder Notification triggered with an incorrect start time.

Cause

There are two possible causes for the issue:

CAUSE 1: This could be caused by manually editing or updating configurations of certain Notification Template from "Manage Data">with Object "EmailTemplate", which will lead to incorrect value of "dueDateDelta" field.  Setting the value for "dueDateDelta" in Manage Data will change the triggering time of the Reminder Notifications. 

CAUSE 2: If the supposed behavior is on Calendar days, the notification might be sent at the incorrect date due to reminderUseBusinessDays is Enabled.

Resolution

RESOLUTION 1:

  1. Navigate to "Manage Data".
  2. Choose Object "EmailTemplate"
  3. Search the template with problem
  4. Remove the value of "dueDateDelta"

RESOLUTION 2:

  1. Navigate to "Manage Data".
  2. Choose Object "EmailTemplate"
  3. Search the template with problem
  4. Set the value of "reminderUseBusinessDays" to No

Keywords

Email, Services, Reminder, notification, dueDateDelta, Frequency, days, number, onboarding, sent, due, date, onb, obx, reminderBeforeDueDateCount , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions