Symptom
Reminder Notification not triggered appropriately according to the Set Up Reminder configuration from Email Services.
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Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Configured Set Up Reminder> Ser reminder before the due date
- Set up "Frequency of reminders in days"=1, "Number of reminders to be sent"=5
- For some candidates, Reminder Notification not triggered, and for other candidates, Reminder Notification triggered with an incorrect start time.
Cause
There are two possible causes for the issue:
CAUSE 1: This could be caused by manually editing or updating configurations of certain Notification Template from "Manage Data">with Object "EmailTemplate", which will lead to incorrect value of "dueDateDelta" field. Setting the value for "dueDateDelta" in Manage Data will change the triggering time of the Reminder Notifications.
CAUSE 2: If the supposed behavior is on Calendar days, the notification might be sent at the incorrect date due to reminderUseBusinessDays is Enabled.
Resolution
RESOLUTION 1:
- Navigate to "Manage Data".
- Choose Object "EmailTemplate"
- Search the template with problem
- Remove the value of "dueDateDelta"
RESOLUTION 2:
- Navigate to "Manage Data".
- Choose Object "EmailTemplate"
- Search the template with problem
- Set the value of "reminderUseBusinessDays" to No
Keywords
Email, Services, Reminder, notification, dueDateDelta, Frequency, days, number, onboarding, sent, due, date, onb, obx, reminderBeforeDueDateCount, Unable to find any EmailReminderState for triggerName, CancelReminderImpl , KBA , LOD-SF-OBX-EML , Notifications , Problem
SAP Knowledge Base Article - Public