Symptom
A customer (or supplier) was created via the Fiori app Migration Cockpit with a success message, but the customer/supplier is missing in the system or the customer/supplier number is different than the one specified in the migration.
Environment
SAP S/4HANA Cloud Public Edition.
Cause
This occurs when a BP grouping specified in the migration sheet has an internal number range assigned. The customer/supplier will be created with the next available number from the internal number range assigned to the BP grouping in the migration.
BP Groupings and their assigned number ranges can be checked in SSCUI 102241 - Define Groupings and Assign Number Ranges, and the corresponding number range can be verified in SSCUI 102296 - Define Number Ranges.
Resolution
If the customer or supplier number is intended to be created as it's maintained in the template file of the Migration Object, then choose a BP grouping with an external number range.
See Also
Official documentation of the Migration Objects:
Keywords
Data, Migration, Cockpit, Migrate, Your, Data, BP, BP02, BP01, Internal, Missing, Customer, Supplier, different, number, range, group. , KBA , LO-MD-BP-MIG , Business Partner Migration , How To