SAP Knowledge Base Article - Public

3091148 - Candidate is not Visible in Dashboard - Onboarding

Symptom

When hiring a candidate from RCM the new hire is not appearing in the Onboarding Dashboard.

Environment

SAP SuccessFactors Onboarding

Cause

Cause 1: An invalid username/email was entered for the candidate. Some invalid special characters was entered.

Cause 2: Phone information was not passed from Recruitment side. "Cannot insert NULL or update to NULL: Not nullable "PHONE_NUMBER" column"

Cause 3: Candidate has landed into rehire verification tile.

Cause 4: Mandatory data missing on Onboarding initiation.

Resolution

Solution 1:

For the candidate username/email entered cannot have a special character, please use the following character types: ['a' to 'z', 'A' to 'Z', '0' to '9', '-', '_', '.', '@']

SAP Support, please check the internal memo.

Solution 2:

  1. Please kindly check the mapping and value from RCM, make sure value is sent to "PHONE_NUMBER".
  2. Then please go to BPE: manage process task with the Job ID, select the ID and click on Restart Task button.

Solution 3:

  1. Proxy as rehire Coordinator.
  2. Complete the rehire verification step. Post this the candidate will appear in onboarding dashboard.

Solution 4:

Use the Check tool (3384146 - Quality check in check tool - Onboarding) to validate missing data. Any mandatory field needs to be mapped on Recruit to hire data tool and valid value need to be sent from RCM side.

See Also

3384146 - Quality check in check tool - Onboarding

Keywords

candidate, appear, Dashboard, available, show, Obx, Onboarding, Username, Email, Special, Characters, Name, User, Valid, Cannot, Insert, NULL, Update, Nullable, PHONE_NUMBER, Column, "Cannot insert NULL or update to NULL: Not nullable "PHONE_NUMBER" column" , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem

Product

SAP SuccessFactors Onboarding all versions