Symptom
You have extracted Customer Contracts from the system and when performing a migration of this Contract, the Start and End Dates differ between contracts.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Contracts view.
- Search for ID ABC and XYZ (ABC and XYZ represents the ID of the migrated Contract).
- Open Contract ABC and XYZ.
- You see that Start and End Date differ between contracts.
Cause
The data extraction pulls the data from the backend and the values in the backend are stored in UTC.
The migration service takes the date that is entered in the migration file for the contract start date and considers this date to be associated with the logged in user's timezone
Example:
Logged user's timezone is CET. The service then converts this date to UTC and stores that converted timestamp in the backend. When you open the migrated contract on the UI, you will see the same date that was present in the migration file because the UI converts the UTC timestamp from the backend to the logged in user's timezone. This implementation ensures that we always maintain the date that was entered in the migration template.
Resolution
This is the system expected behavior.
To solve the scenario, you will need to do an additional conversion step after the data extraction and before migration.
This can possibly be performed via an add-on, where you can convert the UTC timestamp in the data extraction file to the timezone in which the contracts were created, and then migrate the data.
See Also
1984439 - Migrated Contracts Have Different Contract Date or Time Than in The Migration Template
Keywords
Migration, Contract, Start, End, Date, Timezone, UTC, Data Extraction , KBA , AP-CCP-CC , Customer Contract , How To